2017-03-28 06:17 CEST

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004645MPDInput Plugins - Filepublic2017-02-15 12:07
ReporterRadek 
Assigned Tocirrus 
PrioritylowSeverityminorReproducibilityalways
StatusclosedResolutionunable to reproduce 
Product Version0.20 
Target VersionFixed in Version 
Summary0004645: mp3 playback
DescriptionI have some mp3 files that behave rly strange: when they finishing its playback, in last 0.5 second or so, they play start of next mp3 file from playlist.

is it bug in MPD or i just compiled with old ffmpeg decoder or so ? one month ago, i was using 0.18 MPD version and everything was working well...

one more note: when i shuffle the playlist, it still plays start of next mp3 file before shuffling... really strange.
TagsNo tags attached.
Attached Files

-Relationships
+Relationships

-Notes

~0010337

Radek (reporter)

same behavior on alsa and pulse...

~0010341

cirrus (administrator)

I assume that you have enabled cross-fading.

~0010344

Radek (reporter)

No cirrus, cross-fading is disabled. i can provide the mp3 file...

~0010345

Radek (reporter)

Its happening only for some mp3 files and it was working well in 0.18...

~0010346

cirrus (administrator)

Then do a git bisect between v0.18 and the version you're using. This will point to the faulty change. Reopen this ticket as soon as you're finished.

I'm closing this ticket now because you have provided zero information, but you're still asking me about whether you're using an old FFmpeg version. How can I know when you don't tell me?

Oh, and "priority urgent" - let's see if this is urgent enough for you to urgently finish the bisect.

~0010347

Radek (reporter)

I apologize i'm newbie with git/c++ development on linux, i know nothing about bisect so it will take a bit, i'll try... :/

just question, could it be caused by old ffmpeg too ?
+Notes

-Issue History
Date Modified Username Field Change
2017-02-13 06:21 Radek New Issue
2017-02-13 06:21 Radek Status new => assigned
2017-02-13 06:21 Radek Assigned To => cirrus
2017-02-13 06:29 Radek Note Added: 0010337
2017-02-15 08:31 cirrus Status assigned => closed
2017-02-15 08:31 cirrus Resolution open => no change required
2017-02-15 08:31 cirrus Note Added: 0010341
2017-02-15 11:33 Radek Status closed => feedback
2017-02-15 11:33 Radek Resolution no change required => reopened
2017-02-15 11:33 Radek Note Added: 0010344
2017-02-15 11:35 Radek Note Added: 0010345
2017-02-15 11:35 Radek Status feedback => assigned
2017-02-15 11:39 cirrus Status assigned => closed
2017-02-15 11:39 cirrus Resolution reopened => fixed
2017-02-15 11:39 cirrus Note Added: 0010346
2017-02-15 11:39 cirrus Priority urgent => low
2017-02-15 11:39 cirrus Resolution fixed => unable to reproduce
2017-02-15 11:39 cirrus Severity major => minor
2017-02-15 12:03 Radek Status closed => feedback
2017-02-15 12:03 Radek Resolution unable to reproduce => reopened
2017-02-15 12:03 Radek Note Added: 0010347
2017-02-15 12:07 cirrus Status feedback => closed
2017-02-15 12:07 cirrus Resolution reopened => unable to reproduce
+Issue History