MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000353MPDpublic2005-01-23 02:442006-03-08 01:25
Reporternormalperson 
Assigned Toshank 
PrioritynormalSeverityfeatureReproducibilityalways
StatusclosedResolutionfixed 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000353: ogg-tremor support
DescriptionI'm not sure when I'll have time for this, so maybe someone will see this and implement it so I don't have to :)

Ogg-tremor is a Ogg-vorbis decoder library that relies integer math instead of floating-point, which would benefit machines without an FPU like the ipod.

TagsNo tags attached.
Attached Files

- Relationships

-  Notes
(0000561)
Anonymous (viewer)
2005-07-18 13:42

This patch
 http://reich.sdf-eu.org/hannes/code/mpd-0.11.2-tremorSupport-1.0.patch [^]
adds a configure option to use tremor instead of libogg.

The change to the ogg plugin code is harmless enough, as the two APIs are almost identical. The configure script is a bit hairier, though, and could use a review from an autoconf guru.

I've tested this successfully on a PC and on a Linksys NSLU2 (big-endian ARM CPU).

Anyone cross-compiling mpd with OpenEmbedded can get the patch by dropping in this replacement bb file http://reich.sdf-eu.org/hannes/code/mpd_0.11.2-tremorSupport.bb [^]

Enjoy :)

/Hannes Reich (hannesATskynetDOTie)
(0000562)
Anonymous (viewer)
2005-07-18 13:47

Looks like the links in the previous note got mangled. The two filenames are "mpd-0.11.2-tremorSupport-1.0.patch" and "mpd_0.11.2-tremorSupport.bb".
(0000583)
normalperson (reporter)
2005-08-25 06:21

Committed to svn (r3453)
(0000689)
Avuton Olrich (administrator)
2006-03-08 01:24

Cleaning up old bugs and found this one.

- Issue History
Date Modified Username Field Change
2005-01-23 02:44 normalperson New Issue
2005-07-18 13:42 Anonymous Note Added: 0000561
2005-07-18 13:47 Anonymous Note Added: 0000562
2005-08-25 06:21 normalperson Note Added: 0000583
2006-03-08 01:24 Avuton Olrich Status assigned => resolved
2006-03-08 01:24 Avuton Olrich Resolution open => fixed
2006-03-08 01:24 Avuton Olrich Note Added: 0000689
2006-03-08 01:25 Avuton Olrich Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker