MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0002321MPDBuildpublic2009-05-06 01:172009-05-23 12:29
ReporterAvuton Olrich 
Assigned Tocirrus 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformamd64OSDebian LinuxOS Version5.0
Product Versiongit 
Target Version0.15Fixed in Versiongit 
Summary0002321: Lame can continue after configure, even if lame libraries don't exist on the system.
Descriptionif gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I. -I. -I./src -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/ -I/usr/include/glib-
2.0 -I/usr/lib/glib-2.0/include -I/usr/include -I/usr/include/libmodplug -I/usr/include/ffmpeg -I/usr/include/alsa -D_REENTRANT -I/u
sr/include/ffmpeg -Wall -Wextra -Wno-deprecated-declarations -Wmissing-prototypes -Wdeclaration-after-statement -Wshadow -Wpointer-arith -Wstrict-prototypes
 -Wcast-qual -Wwrite-strings -pedantic -D_GNU_SOURCE -D_REENTRANT -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -g -O2 -MT src_mpd-lame_encoder.o -
MD -MP -MF ".deps/src_mpd-lame_encoder.Tpo" -c -o src_mpd-lame_encoder.o `test -f 'src/encoder/lame_encoder.c' || echo './'`src/encoder/lame_encoder.c; \
        then mv -f ".deps/src_mpd-lame_encoder.Tpo" ".deps/src_mpd-lame_encoder.Po"; else rm -f ".deps/src_mpd-lame_encoder.Tpo"; exit 1; fi
src/encoder/lame_encoder.c:24:23: error: lame/lame.h: No such file or directory
src/encoder/lame_encoder.c:35: error: expected specifier-qualifier-list before ‘lame_global_flags’
src/encoder/lame_encoder.c: In function ‘lame_encoder_setup’:
src/encoder/lame_encoder.c:138: warning: implicit declaration of function ‘lame_set_VBR’
src/encoder/lame_encoder.c:138: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:138: error: ‘vbr_rh’ undeclared (first use in this function)
src/encoder/lame_encoder.c:138: error: (Each undeclared identifier is reported only once
if gcc -std=gnu99 -DHAVE_CONFIG_H -I. -I. -I. -I./src -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/ -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include -I/usr/include/libmodplug -I/usr/include/ffmpeg -I/usr/include/alsa -D_REENTRANT -I/usr/include/ffmpeg -Wall -Wextra -Wno-deprecated-declarations -Wmissing-prototypes -Wdeclaration-after-statement -Wshadow -Wpointer-arith -Wstrict-prototypes -Wcast-qual -Wwrite-strings -pedantic -D_GNU_SOURCE -D_REENTRANT -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -g -O2 -MT src_mpd-output_list.o -MD -MP -MF ".deps/src_mpd-output_list.Tpo" -c -o src_mpd-output_list.o `test -f 'src/output_list.c' || echo './'`src/output_list.c; \
src/encoder/lame_encoder.c:138: error: for each function it appears in.) then mv -f ".deps/src_mpd-output_list.Tpo" ".deps/src_mpd-output_list.Po"; else rm -f ".deps/src_mpd-output_list.Tpo"; exit 1; fi

src/encoder/lame_encoder.c:143: warning: implicit declaration of function ‘lame_set_VBR_q’
src/encoder/lame_encoder.c:143: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:151: warning: implicit declaration of function ‘lame_set_brate’
src/encoder/lame_encoder.c:151: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:158: warning: implicit declaration of function ‘lame_set_num_channels’
src/encoder/lame_encoder.c:158: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:165: warning: implicit declaration of function ‘lame_set_in_samplerate’
src/encoder/lame_encoder.c:165: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:172: warning: implicit declaration of function ‘lame_init_params’
src/encoder/lame_encoder.c:172: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c: In function ‘lame_encoder_open’:
src/encoder/lame_encoder.c:192: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:192: warning: implicit declaration of function ‘lame_init’
src/encoder/lame_encoder.c:193: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:200: warning: implicit declaration of function ‘lame_close’
src/encoder/lame_encoder.c:200: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:204: error: ‘struct lame_encoder’ has no member named ‘buffer_length’
src/encoder/lame_encoder.c: In function ‘lame_encoder_close’:
src/encoder/lame_encoder.c:214: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c: In function ‘lame_encoder_write’:
src/encoder/lame_encoder.c:229: error: ‘struct lame_encoder’ has no member named ‘buffer_length’
src/encoder/lame_encoder.c:243: warning: implicit declaration of function ‘lame_encode_buffer_float’
src/encoder/lame_encoder.c:243: error: ‘struct lame_encoder’ has no member named ‘gfp’
src/encoder/lame_encoder.c:244: error: ‘struct lame_encoder’ has no member named ‘buffer’
src/encoder/lame_encoder.c:245: error: ‘struct lame_encoder’ has no member named ‘buffer’
src/encoder/lame_encoder.c:256: error: ‘struct lame_encoder’ has no member named ‘buffer_length’
src/encoder/lame_encoder.c: In function ‘lame_encoder_read’:
src/encoder/lame_encoder.c:265: error: ‘struct lame_encoder’ has no member named ‘buffer_length’
src/encoder/lame_encoder.c:266: error: ‘struct lame_encoder’ has no member named ‘buffer_length’
src/encoder/lame_encoder.c:268: error: ‘struct lame_encoder’ has no member named ‘buffer’
src/encoder/lame_encoder.c:270: error: ‘struct lame_encoder’ has no member named ‘buffer_length’
src/encoder/lame_encoder.c:271: error: ‘struct lame_encoder’ has no member named ‘buffer’
src/encoder/lame_encoder.c:271: error: ‘struct lame_encoder’ has no member named ‘buffer’
src/encoder/lame_encoder.c:272: error: ‘struct lame_encoder’ has no member named ‘buffer_length’
make[1]: *** [src_mpd-lame_encoder.o] Error 1
make[1]: *** Waiting for unfinished jobs....
TagsNo tags attached.
Attached Fileslog file icon config.log [^] (53,823 bytes) 2009-05-06 09:27

- Relationships

-  Notes
(0003768)
Avuton Olrich (administrator)
2009-05-06 01:46

Very very strange, but I can't reproduce this now. I removed libmp3lame-dev and libmp3lame0 and can't get this to reoccur. Any ideas how I did this? ;)
(0003769)
cirrus (administrator)
2009-05-06 09:03

Attach your config.log.
(0003770)
Avuton Olrich (administrator)
2009-05-06 09:27

There it is, I was able to reproduce after all.
(0003771)
Avuton Olrich (administrator)
2009-05-06 09:32

hrm, maybe this isn't a bug, I inadvertently had lametest disabled. Why is this possible? :)
(0003772)
cirrus (administrator)
2009-05-06 09:39

Maybe during autoreconfigure, when autoconf remembered --disable-lametest, but you explicitly specified --enable-lame-encoder?
(0003773)
Avuton Olrich (administrator)
2009-05-06 09:46

Actually, even simpler than that, I simply added it to a list of arguments I had to configure. It can be simplified as such:

make distclean; ./autogen.sh --enable-lame-encoder --disable-lametest; make

Which makes me wonder why disabling lametest is wanted at all.
(0003774)
cirrus (administrator)
2009-05-06 09:49

This option is bogus for our use. It's defined in m4/lame.m4, which was borrowed from some other project. We should remove the option.
(0003775)
Avuton Olrich (administrator)
2009-05-06 09:57

OK, I'll work on this.

- Issue History
Date Modified Username Field Change
2009-05-06 01:17 Avuton Olrich New Issue
2009-05-06 01:17 Avuton Olrich Status new => assigned
2009-05-06 01:17 Avuton Olrich Assigned To => cirrus
2009-05-06 01:46 Avuton Olrich Note Added: 0003768
2009-05-06 09:03 cirrus Note Added: 0003769
2009-05-06 09:27 Avuton Olrich File Added: config.log
2009-05-06 09:27 Avuton Olrich Note Added: 0003770
2009-05-06 09:32 Avuton Olrich Note Added: 0003771
2009-05-06 09:39 cirrus Note Added: 0003772
2009-05-06 09:46 Avuton Olrich Note Added: 0003773
2009-05-06 09:49 cirrus Note Added: 0003774
2009-05-06 09:57 Avuton Olrich Note Added: 0003775
2009-05-15 16:37 cirrus Status assigned => resolved
2009-05-15 16:37 cirrus Fixed in Version => git
2009-05-15 16:37 cirrus Resolution open => fixed
2009-05-23 12:29 Avuton Olrich Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker