MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001670MPDInterfacepublic2008-04-08 15:452009-01-24 16:33
Reportercweiske 
Assigned Tocirrus 
PrioritylowSeverityfeatureReproducibilityalways
StatusassignedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0001670: provide UPNP media renderer interface
DescriptionIt would be cool if mpd would act as a UPNP media renderer. This way one can sync playback between multiple UPNP capable players, and control mpd via upnp media controllers.
Additional Information- http://gupnp.org/ [^]
- http://www.cidero.com/ [^]
TagsNo tags attached.
Attached Files

- Relationships
duplicate of 0001924assignedcirrus Concider implementing a UPnP/DLNA server inside MPD 

-  Notes
(0002753)
Avuton Olrich (administrator)
2009-01-02 15:26

The other bug is a bit more descriptive in what is wanted. Please add yourself to it.
(0002755)
cweiske (reporter)
2009-01-02 15:53

This is not a duplicate but a complementing feature.
The other bug is about MPD acting as an UPnP server, while I'd like to see MPD be controllable like any other UPnP client (renderer).
(0002928)
Avuton Olrich (administrator)
2009-01-24 06:57

Actually, this is a really cool idea, if I understand correctly, it would be like using mediatomb as a backend, an alternate to the internal MPD database, right?
(0002930)
cweiske (reporter)
2009-01-24 10:53
edited on: 2009-01-24 10:55

> if I understand correctly, it would be like
> using mediatomb as a backend, an alternate
> to the internal MPD database
Partly. Using an UPnP server as backend is one part of it, the other part I imagined is that mpd would act as a normal UPnP client and could be controllable via UPnP - play, pause, louder, quieter, skip to next song etc. Once the upnp-server-as-backend would be implemented, one could even create playlists remotely via upnp.

(0002931)
cirrus (administrator)
2009-01-24 13:08

Sounds like an interesting idea. cweiske, do you want to implement that? We are currently busy with implementing other features, and it may take a while until we can look into the UPnP stuff.
(0002934)
cweiske (reporter)
2009-01-24 16:33

Sorry, but my TODO is totally filled up with own PHP projects (PEAR etc.), and my C skills suck :)

- Issue History
Date Modified Username Field Change
2008-04-08 15:45 cweiske New Issue
2008-04-08 15:45 cweiske Status new => assigned
2008-04-08 15:45 cweiske Assigned To => shank
2008-10-25 19:00 Avuton Olrich Assigned To shank => cirrus
2008-10-25 21:43 Avuton Olrich Category => Interface
2009-01-02 15:26 Avuton Olrich Note Added: 0002753
2009-01-02 15:26 Avuton Olrich Relationship added duplicate of 0001924
2009-01-02 15:26 Avuton Olrich Duplicate ID 0 => 1924
2009-01-02 15:26 Avuton Olrich Status assigned => resolved
2009-01-02 15:26 Avuton Olrich Resolution open => duplicate
2009-01-02 15:53 cweiske Note Added: 0002755
2009-01-02 15:53 cweiske Status resolved => feedback
2009-01-02 15:53 cweiske Resolution duplicate => reopened
2009-01-03 22:53 Avuton Olrich Status feedback => assigned
2009-01-04 15:33 cirrus Priority normal => low
2009-01-24 06:57 Avuton Olrich Note Added: 0002928
2009-01-24 10:53 cweiske Note Added: 0002930
2009-01-24 10:55 cweiske Note Edited: 0002930
2009-01-24 13:08 cirrus Note Added: 0002931
2009-01-24 16:33 cweiske Note Added: 0002934


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker